News

Slow down light and ventilation questions

Discussion in 'Mondial' started by 88MONDIAL, May 20, 2019.

  1. 88MONDIAL

    88MONDIAL Formula 3

    Apr 13, 2005
    1,005
    Racine, Wisconsin
    Full Name:
    Jim Smith
    I have to unrelated questions. When I bought my Mondial 8 in 2016, I got a slow down light the very first ride with it. Lasted 2-3min's and only a few miles from my house - car wasn't even warm yet. It's NEVER gone on again. But when I took my car in for the oil change in 2017 it was pointed out that I don't have cats, I have test pipes. I'm assuming if I would ever get a slow down light again, it would be totally erroneous. Is that correct?

    Second question is my car only blows HOT air out of the vents (after major this past fall, my A/C was deemed to hold a charge and it's converted to R134). I tried that too and only hot. Not a biggie as I just set the system to OFF and put the windows down. Any idea what part or issue could cause this? It's always done this, I was hoping that after my major and the AC seems to "work", that at least I could get cool air.

    thanks!
    Jim
     
  2. Wade

    Wade Two Time F1 World Champ
    Rossa Subscribed Owner

    Mar 31, 2006
    28,770
    East Central, FL
    Full Name:
    Wade O.
    1. I seem to recall that the Slow Down lights are/were directly wired to the Cat's thermocouples. No Cats = no serious problems. So, first question, do the test pipes have ports for the thermocouples (I can't imagine why)?

    2. The heater control valve - possibly the valve itself is the problem, or the interior temp sensor has failed. There are several really good threads in this.
     
  3. 88MONDIAL

    88MONDIAL Formula 3

    Apr 13, 2005
    1,005
    Racine, Wisconsin
    Full Name:
    Jim Smith
    Thanks Wade! Yea, there weren't any wires/sensors going to the test pipes.
     

Share This Page