News

Mondial 8 no start

Discussion in 'Mondial' started by ATSAaron, Sep 17, 2019.

  1. ATSAaron

    ATSAaron Formula 3
    Silver Subscribed

    Jun 1, 2004
    1,077
    Shady Shores, TX
    Full Name:
    Aaron Bunch
    I brought home the electrical manual (for a QV) but I thought I would ask here first.

    My Mondial 8 has an electrical issue. I turn the key to ON and only the alternator warning light comes on. No AC fan, no parking brake or slow down warnings.

    Turn to START and nothing happens.

    So do I look at the switch first or the fuse/relay box?

    Thanks,

    Aaron
     
  2. To remove this ad click here.

  3. ATSAaron

    ATSAaron Formula 3
    Silver Subscribed

    Jun 1, 2004
    1,077
    Shady Shores, TX
    Full Name:
    Aaron Bunch
    After reviewing the wiring diagrams I am convinced that I actually have two separate problems. Most likely the ignition switch relay (bottom row, second from the left) and the starter circuit of the ignition switch itself.
     
  4. Wade

    Wade Three Time F1 World Champ
    Rossa Subscribed Owner

    Mar 31, 2006
    32,194
    East Central, FL
    Full Name:
    Wade O.

    Attached Files:

  5. ATSAaron

    ATSAaron Formula 3
    Silver Subscribed

    Jun 1, 2004
    1,077
    Shady Shores, TX
    Full Name:
    Aaron Bunch
    Fixed. The problem was a combination of things. The fuse/relay diagram in the factory electrical manual is WRONG. This caused me to swap around some of the relays and create more problems. The no-start issue was just some wear on the ignition switch. Installing a starter relay (there is not one from the factory) has solved this issue.

    Aaron
     
    Wade and 2cam like this.
  6. 2cam

    2cam Formula Junior

    Aug 28, 2014
    634
    Austin, Texas
    Full Name:
    MikeS
    Glad that you were able to sort it out! What starter relay did you use?
     
  7. To remove this ad click here.

  8. ATSAaron

    ATSAaron Formula 3
    Silver Subscribed

    Jun 1, 2004
    1,077
    Shady Shores, TX
    Full Name:
    Aaron Bunch
    It's just a generic Pico brand 30 amp relay and connector. I installed it under the dash near the connector for the ignition key switch. I depinned the white wire on both sides of the stock connector and added male/female crimp connectors to the relay connector pigtail. Then I tee-d into the blue power wire at the ignition key switch connector and found a ground spot under the steering column.
     
  9. theunissenguido

    theunissenguido Formula 3
    Silver Subscribed Owner

    Jan 21, 2004
    1,702
    Argent/Brasil
    Full Name:
    Guido
    Fuseboard for mondial 8 has a different internal diagram then mondial QV....so you cannot use the mondial QV wiring diagram.I have a new mondial 8 recreated board in stock in case you need one. Start a conversation to know more about this.
    Guido
     
  10. Tyler9321

    Tyler9321 Rookie

    May 9, 2019
    4
    Chicago
    Full Name:
    Tyler k harper
    It seems like I am having an identical problem as you had. The car ran and drove fine and now when I turn the key, only that battery/alternator light comes on, nothing else at all. It will turn over and over but never start. I tried replacing a few relays and fuses, still nothing. Where do I look/ what did you exactly do to solve this problem. Thanks
     
  11. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,381
    Uk
    Is the fuel pump runnng and do you have volts at the coils
     
  12. To remove this ad click here.

  13. Tyler9321

    Tyler9321 Rookie

    May 9, 2019
    4
    Chicago
    Full Name:
    Tyler k harper
    No I don’t
     
  14. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,381
    Uk
    I only have the wiring diagram for the 3.2 so might be different, from the keyswitch look for 2 off yellow wires- one is the supply to the coils and the other goes to terminal 13 on the connector for the ignition module- from what i can see this is a multipin plug in . There is a fuse and a relay for the fuel pump.
    With no coil or fuel pump you need to check you have volts at the key switch
     
  15. Tyler9321

    Tyler9321 Rookie

    May 9, 2019
    4
    Chicago
    Full Name:
    Tyler k harper
    Okay thank you, I will check it out and see what’s going on. Appreciate the help
     
  16. mike32

    mike32 F1 Rookie

    May 13, 2016
    3,381
    Uk
    Thinking about it, i think the ignition module is the electronic box situated in front of one of the rear wheel wells.
    If i remember correct you need to remove a rear wheel and the wheel liner
    It is a big box with a multi pin connector i think, long time since my mondial
    Others on here might like to chime in with more knowledge than me
     
  17. Tyler9321

    Tyler9321 Rookie

    May 9, 2019
    4
    Chicago
    Full Name:
    Tyler k harper
    I replaced the relay for the “switch by key”, cleaned the contacts for the ignition and tried it before taking it apart. It worked so I took it for a drive and tried a few more times, it seems to be working well now. Thank you for help
     
    Wade likes this.

Share This Page