News

California DCT Speed Sensor Service

Discussion in 'California & Nevada (Northern)' started by Mhoram, Aug 22, 2020.

  1. Mhoram

    Mhoram Rookie

    Apr 15, 2009
    12
    Any shop recommendations in the south bay to replace the speed sensor in a California?

    Sent from my SM-G973U using Tapatalk
     
  2. To remove this ad click here.

  3. simmadwn

    simmadwn Formula Junior
    Silver Subscribed

    Jun 10, 2016
    328
    San Mateo, CA
    Full Name:
    James
    SanFrancisco Motorsport in San Rafael...Jesse
     
  4. yelcab

    yelcab F1 World Champ
    Consultant

    Nov 29, 2001
    10,665
    San Carlos, CA
    Full Name:
    Mitchell Le
    SF Motorsport is not in the south bay.
    Roselli is.
     
  5. Mhoram

    Mhoram Rookie

    Apr 15, 2009
    12
    I ended up having the car AAA up to SF Motorsports this morning.

    Hoping they can get the tranmission fixed so I can have a proper introduction to the car as I just got it delivered and it is my 1st Ferrari.



    Sent from my SM-G973U using Tapatalk
     
    simmadwn likes this.
  6. dinoart

    dinoart Formula Junior
    Silver Subscribed

    Oct 30, 2004
    460
    Westminster CA
    Full Name:
    David
    What year?
     
  7. To remove this ad click here.

  8. simmadwn

    simmadwn Formula Junior
    Silver Subscribed

    Jun 10, 2016
    328
    San Mateo, CA
    Full Name:
    James
    Lol...that was the first question I asked too...its a 2010 apparently.
     
  9. Mhoram

    Mhoram Rookie

    Apr 15, 2009
    12
    2010 with 56k miles

    Sent from my SM-G973U using Tapatalk
     
  10. action-ant

    action-ant Karting

    Nov 16, 2015
    166
    San Francisco, CA
    Full Name:
    Anthony
    Good luck keep us posted. How was it diagnosed to be the speed sensor?
     
  11. Mhoram

    Mhoram Rookie

    Apr 15, 2009
    12
    It was blocking even gears and my code reader showed the following codes after I cleared them and went on another drive.

    They will confirm the diagnostic once the transmission is open. Image Unavailable, Please Login

    Sent from my SM-G973U using Tapatalk
     
  12. To remove this ad click here.

  13. Mhoram

    Mhoram Rookie

    Apr 15, 2009
    12
    Looks like once they opened up the transmission it was the SAP module that was the issue.

    Sent from my SM-G973U using Tapatalk
     

Share This Page