News

84 QV front indicators not working

Discussion in 'Mondial' started by rjp80s, Jun 15, 2019.

  1. rjp80s

    rjp80s Rookie

    Jan 24, 2017
    24
    Houston
    Full Name:
    Rick Pleczko
    Hi All,
    I have an 84 QV coupe. The front indicators have just stopped working. The rears work just fine. I changed the bulbs, so I know they're OK. Before I start digging into the electrics, has anybody experienced this, and any suggestions for a fix?

    Help, greatly appreciated.
     
  2. Steve Magnusson

    Steve Magnusson F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    18,730
    Texas
    Full Name:
    Steve Magnusson
    #2 Steve Magnusson, Jun 15, 2019
    Last edited: Jun 15, 2019
    Have you tried to see if the fronts work, or not, when using the emergency flasher? (The rears working is a good sign for the flasher unit itself -- which is also used for the emergency flashing function).

    Our collective experience here would probably have some sort of local grounding problem(s) as the best suspect, but operating the emergency flasher as a test is pretty easy ;)
     
  3. rjp80s

    rjp80s Rookie

    Jan 24, 2017
    24
    Houston
    Full Name:
    Rick Pleczko
    Thanks Steve,
    I just tried the emergency flashers, the front indicators still don't work then the flasher is on. I'll look for grounding problems.
     
  4. Steve Magnusson

    Steve Magnusson F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    18,730
    Texas
    Full Name:
    Steve Magnusson
    What version 1984 Mondial QV?

    The US wiring diagram shows each side has a separate ground. Each ground is also shared by the front turn signal bulb and the front parking light bulb -- is the front parking light bulb also not working on both sides?
     
  5. yelcab

    yelcab F1 Veteran
    Consultant

    Nov 29, 2001
    9,580
    San Carlos, CA
    Full Name:
    Mitchell Le
    the front lights are pretty old and the sockets are crusty from corrosion. Take out the bulbs, clean the wires, clean the connections, clean the sockets and that should solve many of your problem.
     
  6. rjp80s

    rjp80s Rookie

    Jan 24, 2017
    24
    Houston
    Full Name:
    Rick Pleczko
    @Steve, my Mondial is a euro spec version, imported Belgium in 84 and then federalized. One of the front parking lights works (see attached pic). @yelcab, thanks for your suggestion, I’ll clean everything and see if that does the trick


    Sent from my iPhone using FerrariChat.com mobile app View attachment 2722248
     
  7. Steve Magnusson

    Steve Magnusson F1 World Champ
    Lifetime Rossa

    Jan 11, 2001
    18,730
    Texas
    Full Name:
    Steve Magnusson
    Interesting that you mention that "history" - the euro version Mondial QV wiring diagram shows that same common local ground on each side for the turn signal and parking light, but one difference on a euro version is that the side marker light is wired to the turn signal while on a US version the side marker light is a parking light. Consequently, being "federalized" would involve some rewiring (which might have not been done very well ;) -- e.g., Scotchlocks). Good hunting!
     
  8. rjp80s

    rjp80s Rookie

    Jan 24, 2017
    24
    Houston
    Full Name:
    Rick Pleczko
    Thanks Steve


    Sent from my iPhone using FerrariChat.com mobile app
     

Share This Page